$re = '/\"[^"]*\"\s*:\s*\[\s*\],?/sm';
$str = '{
"rootname" : {
"key1" : [ "lbl1", "lbl2" ],
"key2" : 10,
"key3" : [ ],
"key4" : "hello",
"key5" : []
}
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;