#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)\"[^"]*\"\s*:\s*\[\s*\],?"
Local $sString = "{" & @CRLF & _
" "rootname" : {" & @CRLF & _
" "key1" : [ "lbl1", "lbl2" ]," & @CRLF & _
" "key2" : 10," & @CRLF & _
" "key3" : [ ]," & @CRLF & _
" "key4" : "hello"," & @CRLF & _
" "key5" : []" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)