const regex = /\"[^"]*\"\s*:\s*\[\s*\],?/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"[^"]*\\"\\s*:\\s*\\[\\s*\\],?', 'gsm')
const str = `{
"rootname" : {
"key1" : [ "lbl1", "lbl2" ],
"key2" : 10,
"key3" : [ ],
"key4" : "hello",
"key5" : []
}
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);