// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sm)\"[^"]*\"\s*:\s*\[\s*\],?"#).unwrap();
let string = "{
\"rootname\" : {
\"key1\" : [ \"lbl1\", \"lbl2\" ],
\"key2\" : 10,
\"key3\" : [ ],
\"key4\" : \"hello\",
\"key5\" : []
}
}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}