import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"[^\"]*\\\"\\s*:\\s*\\[\\s*\\],?";
final String string = "{\n"
+ " \"rootname\" : {\n"
+ " \"key1\" : [ \"lbl1\", \"lbl2\" ],\n"
+ " \"key2\" : 10,\n"
+ " \"key3\" : [ ],\n"
+ " \"key4\" : \"hello\",\n"
+ " \"key5\" : []\n"
+ " }\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}