# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{(?!0\})|(?<!\{0)\}//gm;t' <<< "AbC{de{0} x{1}}{"