import re
regex = re.compile(r"\{(?!0\})|(?<!\{0)\}", flags=re.MULTILINE)
test_str = "AbC{de{0} x{1}}{"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)