$re = '/\{(?!0\})|(?<!\{0)\}/m';
$str = 'AbC{de{0} x{1}}{';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;