use strict;
my $str = 'AbC{de{0} x{1}}{';
my $regex = qr/\{(?!0\})|(?<!\{0)\}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";