using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?!0\})|(?<!\{0)\}";
string substitution = @"";
string input = @"AbC{de{0} x{1}}{";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}