#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Za-z0-9]{1,}\.[A-Za-z0-9]{1,10}\.?[A-Za-z]{1,}\.?[A-Za-z]{1,}"
Local $sString = "2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if" & @CRLF & _
"2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if" & @CRLF & _
"2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif" & @CRLF & _
"2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top - "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")