import Foundation
let pattern = #"[A-Za-z0-9]{1,}\.[A-Za-z0-9]{1,10}\.?[A-Za-z]{1,}\.?[A-Za-z]{1,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if
2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if
2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif
2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top -
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)