$re = '/[A-Za-z0-9]{1,}\.[A-Za-z0-9]{1,10}\.?[A-Za-z]{1,}\.?[A-Za-z]{1,}/';
$str = '2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if
2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if
2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif
2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top - ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);