use strict;
my $str = '2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if
2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if
2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif
2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top - ';
my $regex = qr/[A-Za-z0-9]{1,}\.[A-Za-z0-9]{1,10}\.?[A-Za-z]{1,}\.?[A-Za-z]{1,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}