import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z0-9]{1,}\\.[A-Za-z0-9]{1,10}\\.?[A-Za-z]{1,}\\.?[A-Za-z]{1,}";
final String string = "2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if\n"
+ "2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if\n"
+ "2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif\n"
+ "2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top - ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}