# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Za-z0-9]{1,}\.[A-Za-z0-9]{1,10}\.?[A-Za-z]{1,}\.?[A-Za-z]{1,}"
test_str = ("2017-03-02: 173.254.221.115 port 80 - www.hlowdolax.top - GET /usp?f=1if\n"
"2017-03-02: 173.254.221.115 port 80 - www.hjaoopoa.top - GET /uf=1if\n"
"2017-03-04: 173.254.221.115 port 80 - www.foolalexas.top - GET /userif\n"
"2017-03-04: 54.202.16.39 port 80 - pentsshoperqunity.top - ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.