#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\s*(\w+)\s*\|\s*(\w+)\s*\|\s*(\w+)\s*\n([^\|]*)(?:\n|$)"
Local $sString = "TTL1 | TTL2 | TTL3" & @CRLF & _
"some text in a line1" & @CRLF & _
"some text in a line2" & @CRLF & _
"some text in a line3" & @CRLF & _
"TTL1 | TTL2 | " & @CRLF & _
"TTL3" & @CRLF & _
"some text in a line1" & @CRLF & _
"some text in a line2" & @CRLF & _
"some text in a line3" & @CRLF & _
"some text in a line4" & @CRLF & _
"some text in a line5" & @CRLF & _
"TTL1 | TTL2 | TTL3" & @CRLF & _
"some text in a line1" & @CRLF & _
"some text in a line2" & @CRLF & _
"some text in a line3" & @CRLF & _
"some text in a line4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")