re = /\s*(\w+)\s*\|\s*(\w+)\s*\|\s*(\w+)\s*\n([^\|]*)(?:\n|$)/
str = 'TTL1 | TTL2 | TTL3
some text in a line1
some text in a line2
some text in a line3
TTL1 | TTL2 |
TTL3
some text in a line1
some text in a line2
some text in a line3
some text in a line4
some text in a line5
TTL1 | TTL2 | TTL3
some text in a line1
some text in a line2
some text in a line3
some text in a line4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end