# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(\w+)\s*\|\s*(\w+)\s*\|\s*(\w+)\s*\n([^\|]*)(?:\n|$)"
test_str = ("TTL1 | TTL2 | TTL3\n"
"some text in a line1\n"
"some text in a line2\n"
"some text in a line3\n"
"TTL1 | TTL2 | \n"
"TTL3\n"
"some text in a line1\n"
"some text in a line2\n"
"some text in a line3\n"
"some text in a line4\n"
"some text in a line5\n"
"TTL1 | TTL2 | TTL3\n"
"some text in a line1\n"
"some text in a line2\n"
"some text in a line3\n"
"some text in a line4")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.