// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\s*(\w+)\s*\|\s*(\w+)\s*\|\s*(\w+)\s*\n([^\|]*)(?:\n|$)").unwrap();
let string = "TTL1 | TTL2 | TTL3
some text in a line1
some text in a line2
some text in a line3
TTL1 | TTL2 |
TTL3
some text in a line1
some text in a line2
some text in a line3
some text in a line4
some text in a line5
TTL1 | TTL2 | TTL3
some text in a line1
some text in a line2
some text in a line3
some text in a line4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}