import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\w+)\\s*\\|\\s*(\\w+)\\s*\\|\\s*(\\w+)\\s*\\n([^\\|]*)(?:\\n|$)";
final String string = "TTL1 | TTL2 | TTL3\n"
+ "some text in a line1\n"
+ "some text in a line2\n"
+ "some text in a line3\n"
+ "TTL1 | TTL2 | \n"
+ "TTL3\n"
+ "some text in a line1\n"
+ "some text in a line2\n"
+ "some text in a line3\n"
+ "some text in a line4\n"
+ "some text in a line5\n"
+ "TTL1 | TTL2 | TTL3\n"
+ "some text in a line1\n"
+ "some text in a line2\n"
+ "some text in a line3\n"
+ "some text in a line4";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}