# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/["'`][^"'`]*(?!\\)["'`](*SKIP)(*F) # Make sure we're not matching inside of quotes, double quotes or backticks
|(?m-s:\s*(?:\-{2}|\#)[^\n]*$) # Single line comment
|(?:
\\/\*.*?\*\\/ # Multi-line comment
(?(?=(?m-s:[\t ]+$)) # Get trailing whitespace if any exists and only if it's the rest of the line
[\t ]+
)
)//gxs;t' <<< "SELECT `#comment inside string`;"