using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""'`][^""'`]*(?!\\)[""'`](*SKIP)(*F) # Make sure we're not matching inside of quotes, double quotes or backticks
|(?m-s:\s*(?:\-{2}|\#)[^\n]*$) # Single line comment
|(?:
\/\*.*?\*\/ # Multi-line comment
(?(?=(?m-s:[\t ]+$)) # Get trailing whitespace if any exists and only if it's the rest of the line
[\t ]+
)
)";
string substitution = @"";
string input = @"SELECT `#comment inside string`;";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}