import re
regex = re.compile(r"""
["'`][^"'`]*(?!\\)["'`](*SKIP)(*F) # Make sure we're not matching inside of quotes, double quotes or backticks
|(?m-s:\s*(?:\-{2}|\#)[^\n]*$) # Single line comment
|(?:
\/\*.*?\*\/ # Multi-line comment
(?(?=(?m-s:[\t ]+$)) # Get trailing whitespace if any exists and only if it's the rest of the line
[\t ]+
)
)
""", flags=re.VERBOSE | re.DOTALL)
test_str = "SELECT `#comment inside string`;"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)