$re = '/["\'`][^"\'`]*(?!\\\\)["\'`](*SKIP)(*F) # Make sure we\'re not matching inside of quotes, double quotes or backticks
|(?m-s:\s*(?:\-{2}|\#)[^\n]*$) # Single line comment
|(?:
\/\*.*?\*\/ # Multi-line comment
(?(?=(?m-s:[\t ]+$)) # Get trailing whitespace if any exists and only if it\'s the rest of the line
[\t ]+
)
)/xs';
$str = 'SELECT `#comment inside string`;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;