import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\"'`][^\"'`]*(?!\\\\)[\"'`](*SKIP)(*F) # Make sure we're not matching inside of quotes, double quotes or backticks\n"
+ "|(?m-s:\\s*(?:\\-{2}|\\#)[^\\n]*$) # Single line comment\n"
+ "|(?:\n"
+ " \\/\\*.*?\\*\\/ # Multi-line comment\n"
+ " (?(?=(?m-s:[\\t ]+$)) # Get trailing whitespace if any exists and only if it's the rest of the line\n"
+ " [\\t ]+\n"
+ " )\n"
+ ")";
final String string = "SELECT `#comment inside string`;";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}