#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+"
Local $sString = "-1234abcd-ab" & @CRLF & _
"abcd12-avc-a" & @CRLF & _
"-abcd-abcdacb" & @CRLF & _
"ac12-acdsde-" & @CRLF & _
"-abcd-abcd--" & @CRLF & _
"abcd-abcdefg" & @CRLF & _
"-abcd-abc--a" & @CRLF & _
"------------" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")