$re = '/(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+/m';
$str = '-1234abcd-ab
abcd12-avc-a
-abcd-abcdacb
ac12-acdsde-
-abcd-abcd--
abcd-abcdefg
-abcd-abc--a
------------
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);