const regex = /(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+', 'gm')
const str = `-1234abcd-ab
abcd12-avc-a
-abcd-abcdacb
ac12-acdsde-
-abcd-abcd--
abcd-abcdefg
-abcd-abc--a
------------
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}