import re
regex = re.compile(r"(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+", flags=re.MULTILINE)
test_str = ("-1234abcd-ab\n"
"abcd12-avc-a\n"
"-abcd-abcdacb\n"
"ac12-acdsde-\n"
"-abcd-abcd--\n"
"abcd-abcdefg\n"
"-abcd-abc--a\n"
"------------\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")