re = /(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+/m
str = '-1234abcd-ab
abcd12-avc-a
-abcd-abcdacb
ac12-acdsde-
-abcd-abcd--
abcd-abcdefg
-abcd-abc--a
------------
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end