using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{12}$)(?=^[^-]*-[^-]*-[^-]*$)[a-zA-Z0-9-]+";
string input = @"-1234abcd-ab
abcd12-avc-a
-abcd-abcdacb
ac12-acdsde-
-abcd-abcd--
abcd-abcdefg
-abcd-abc--a
------------
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}