using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.)(.*?)(?=\.)";
string input = @"configurations.ft_alfa.parentConfig=oma
configurations.ft_bpmlz.parentConfig=oma
configurations.ft_cmp.parentConfig=oma
configurations.ft_coda.parentConfig=oma
configurations.ft_fom.parentConfig=oma
configurations.ft_judocs.parentConfig=oma
configurations.ft_life.parentConfig=oma
configurations.ft_nsf.parentConfig=oma
configurations.ft_ods.parentConfig=oma
configurations.ft_psbohra.parentConfig=oma
configurations.ft_rens.parentConfig=oma
configurations.ft_rosy.parentConfig=oma
configurations.ft_sblp.parentConfig=oma
configurations.ft_sbw.parentConfig=oma
configurations.ft_vzb.parentConfig=oma
configurations.ft_enut.parentConfig=oma
configurations.ft_exut.parentConfig=oma";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}