import re
regex = re.compile(r"(?<=\.)(.*?)(?=\.)", flags=re.MULTILINE)
test_str = ("configurations.ft_alfa.parentConfig=oma\n"
"configurations.ft_bpmlz.parentConfig=oma\n"
"configurations.ft_cmp.parentConfig=oma\n"
"configurations.ft_coda.parentConfig=oma\n"
"configurations.ft_fom.parentConfig=oma\n"
"configurations.ft_judocs.parentConfig=oma\n"
"configurations.ft_life.parentConfig=oma\n"
"configurations.ft_nsf.parentConfig=oma\n"
"configurations.ft_ods.parentConfig=oma\n"
"configurations.ft_psbohra.parentConfig=oma\n"
"configurations.ft_rens.parentConfig=oma\n"
"configurations.ft_rosy.parentConfig=oma\n"
"configurations.ft_sblp.parentConfig=oma\n"
"configurations.ft_sbw.parentConfig=oma\n"
"configurations.ft_vzb.parentConfig=oma\n"
"configurations.ft_enut.parentConfig=oma\n"
"configurations.ft_exut.parentConfig=oma")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")