$re = '/(?<=\.)(.*?)(?=\.)/m';
$str = 'configurations.ft_alfa.parentConfig=oma
configurations.ft_bpmlz.parentConfig=oma
configurations.ft_cmp.parentConfig=oma
configurations.ft_coda.parentConfig=oma
configurations.ft_fom.parentConfig=oma
configurations.ft_judocs.parentConfig=oma
configurations.ft_life.parentConfig=oma
configurations.ft_nsf.parentConfig=oma
configurations.ft_ods.parentConfig=oma
configurations.ft_psbohra.parentConfig=oma
configurations.ft_rens.parentConfig=oma
configurations.ft_rosy.parentConfig=oma
configurations.ft_sblp.parentConfig=oma
configurations.ft_sbw.parentConfig=oma
configurations.ft_vzb.parentConfig=oma
configurations.ft_enut.parentConfig=oma
configurations.ft_exut.parentConfig=oma';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);