use strict;
my $str = 'configurations.ft_alfa.parentConfig=oma
configurations.ft_bpmlz.parentConfig=oma
configurations.ft_cmp.parentConfig=oma
configurations.ft_coda.parentConfig=oma
configurations.ft_fom.parentConfig=oma
configurations.ft_judocs.parentConfig=oma
configurations.ft_life.parentConfig=oma
configurations.ft_nsf.parentConfig=oma
configurations.ft_ods.parentConfig=oma
configurations.ft_psbohra.parentConfig=oma
configurations.ft_rens.parentConfig=oma
configurations.ft_rosy.parentConfig=oma
configurations.ft_sblp.parentConfig=oma
configurations.ft_sbw.parentConfig=oma
configurations.ft_vzb.parentConfig=oma
configurations.ft_enut.parentConfig=oma
configurations.ft_exut.parentConfig=oma';
my $regex = qr/(?<=\.)(.*?)(?=\.)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}