import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.)(.*?)(?=\\.)";
final String string = "configurations.ft_alfa.parentConfig=oma\n"
+ "configurations.ft_bpmlz.parentConfig=oma\n"
+ "configurations.ft_cmp.parentConfig=oma\n"
+ "configurations.ft_coda.parentConfig=oma\n"
+ "configurations.ft_fom.parentConfig=oma\n"
+ "configurations.ft_judocs.parentConfig=oma\n"
+ "configurations.ft_life.parentConfig=oma\n"
+ "configurations.ft_nsf.parentConfig=oma\n"
+ "configurations.ft_ods.parentConfig=oma\n"
+ "configurations.ft_psbohra.parentConfig=oma\n"
+ "configurations.ft_rens.parentConfig=oma\n"
+ "configurations.ft_rosy.parentConfig=oma\n"
+ "configurations.ft_sblp.parentConfig=oma\n"
+ "configurations.ft_sbw.parentConfig=oma\n"
+ "configurations.ft_vzb.parentConfig=oma\n"
+ "configurations.ft_enut.parentConfig=oma\n"
+ "configurations.ft_exut.parentConfig=oma";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}