#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z]{2}\.[A-Za-z][0-9]\.[0-9]{3}"
Local $sString = "as.d3.987" & @CRLF & _
"Ac.p9.432" & @CRLF & _
"as .d3.987" & @CRLF & _
"Ac. p9.432" & @CRLF & _
"a1.d3.987" & @CRLF & _
"Ac.9p.432" & @CRLF & _
"xZ.O7.102" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")