$re = '/[A-Za-z]{2}\.[A-Za-z][0-9]\.[0-9]{3}/m';
$str = 'as.d3.987
Ac.p9.432
as .d3.987
Ac. p9.432
a1.d3.987
Ac.9p.432
xZ.O7.102
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);