const regex = /[A-Za-z]{2}\.[A-Za-z][0-9]\.[0-9]{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]{2}\\.[A-Za-z][0-9]\\.[0-9]{3}', 'gm')
const str = `as.d3.987
Ac.p9.432
as .d3.987
Ac. p9.432
a1.d3.987
Ac.9p.432
xZ.O7.102
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}