import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z]{2}\\.[A-Za-z][0-9]\\.[0-9]{3}";
final String string = "as.d3.987\n"
+ "Ac.p9.432\n"
+ "as .d3.987\n"
+ "Ac. p9.432\n"
+ "a1.d3.987\n"
+ "Ac.9p.432\n"
+ "xZ.O7.102\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}