re = /[A-Za-z]{2}\.[A-Za-z][0-9]\.[0-9]{3}/m
str = 'as.d3.987
Ac.p9.432
as .d3.987
Ac. p9.432
a1.d3.987
Ac.9p.432
xZ.O7.102
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end