package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z]{2}\.[A-Za-z][0-9]\.[0-9]{3}`)
var str = `as.d3.987
Ac.p9.432
as .d3.987
Ac. p9.432
a1.d3.987
Ac.9p.432
xZ.O7.102
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}