#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\s*span[^>]*>(.*?)<\s*\/\s*span>"
Local $sString = " <div class="col-9 ml-auto text-right p-0">" & @CRLF & _
" <span id="allPopulation" class=" allPopulation number-lg">32.519</span>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")