const regex = /<\s*span[^>]*>(.*?)<\s*\/\s*span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*span[^>]*>(.*?)<\\s*\\\/\\s*span>', 'gm')
const str = ` <div class="col-9 ml-auto text-right p-0">
<span id="allPopulation" class=" allPopulation number-lg">32.519</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}