import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*span[^>]*>(.*?)<\\s*\\/\\s*span>";
final String string = " <div class=\"col-9 ml-auto text-right p-0\">\n"
+ " <span id=\"allPopulation\" class=\" allPopulation number-lg\">32.519</span>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}