using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*span[^>]*>(.*?)<\s*\/\s*span>";
string input = @" <div class=""col-9 ml-auto text-right p-0"">
<span id=""allPopulation"" class="" allPopulation number-lg"">32.519</span>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}