// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<\s*span[^>]*>(.*?)<\s*\/\s*span>").unwrap();
let string = " <div class=\"col-9 ml-auto text-right p-0\">
<span id=\"allPopulation\" class=\" allPopulation number-lg\">32.519</span>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}