using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$";
string input = @"email@example.com
firstname.lastname@example.com
email@subdomain.example.com
1234567890@example.com
email@example-one.com
firstname-lastname@example.com
jpemail@example.co.jp
""email""@example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}