re = /^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$/m
str = 'email@example.com
firstname.lastname@example.com
email@subdomain.example.com
1234567890@example.com
email@example-one.com
firstname-lastname@example.com
jpemail@example.co.jp
"email"@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end